`

1006. Sign In and Sign Out (25)

c++ 
阅读更多
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

AC参考代码:
#include<iostream>
#include<string.h>
#include <fstream>

using namespace std;
 
 
int main()
{
	//ifstream cin("1.txt");
    string names[1001],signIn[1001],signOut[1001],min,max,name,name1;
    int M;
 
    cin>>M;
    cin>>name>>min>>max;
    name1 = name;
    for(int i=1; i<M; i++)
    {
        cin>>names[i]>>signIn[i]>>signOut[i];
        if(strcmp(signIn[i].c_str(),min.c_str()) <= 0)
        {
            min = signIn[i];
            name = names[i];
        }
        if(strcmp(signOut[i].c_str(),max.c_str()) >= 0)
        {
            max = signOut[i];
            name1  = names[i];
        }
    }
    cout<<name<<" "<<name1<<endl;
    return 0;
}


索引都是一一对应的,设置初始最大值和最小值,找数组中的最值问题,一次遍历完成

水水过了~~~

0
0
分享到:
评论

相关推荐

    A pracitcal introduction to hardware software codesign

    1.3 The Driving Factors in Hardware/Software Codesign.. . . . . . . . . . . . . . . 15 1.4 The Hardware–Software Codesign Space. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17 1.4.1 The ...

    EX.rar_The One And Only_cycle delay vhdl_shift_shift left_test p

    2. Input pins: SHIFT [3:0], IN [15:0], SIGN, RIGHT. 3. Output pins: OUT [15:0]. 4. Input signals generated from test pattern are latched in one cycle and are synchronized at clock rising edge. 5. The ...

    Google C++ International Standard.pdf

    3 Terms and definitions 3 4 General principles 7 4.1 Implementation compliance . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7 4.2 Structure of this document . . . . . . . . . ...

    SystemVerilog Reference Manual 3.1a(中英文版)+最新SV IEEE 标准

    2.3 Integer and logic literals ..................................................................................................................4 2.4 Real literals ......................................

    Optimization Modelling A Practical Approach

    2.6 Deriving a Solution..............................................................................25 2.7 Sensitivity Analysis ..........................................................................

    Big Data Analytics with Applications in Insider Threat Detection-CRC(2018).pdf

    The signi cant developments in data management and analytics, web services, cloud computing, and cyber security have evolved into an area called big data management and analytics (BDMA) as well as big...

    C++ 标准 ISO 14882-2011

    1.10 Multi-threaded executions and data races . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12 1.11 Acknowledgments . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ...

    poj 1004 Financial Management

    It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output. Sample Input 100.00 489....

    Python_Data Analytics and Visualization_A Course in Three Modules-(2017)

    In nance, business, administration and the natural or social sciences, working with data can make up a signi cant part of the job. Being able to ef ciently work with small or large datasets has ...

    MAILPLANE 3.8.2 FOR MAC

    No need to sign-out and sign-in. Google Calendar is a perfect match for Gmail. Mailplane combines them in one app. No separate calendar set-up required and accepting an invitation intuitively ...

    Nvidia xavier user guide

    0. Sign up for the NVIDIA Developer Program – this enables you to ask questions and contribute on the NVIDIA Jetson Forums, gives access to all documentation and collateral on the Jetson Download ...

    Python_Data+Analytics+and+Visualization-Packt+Publishing(2017).pdf

    In nance, business, administration and the natural or social sciences, working with data can make up a signi cant part of the job. Being able to ef ciently work with small or large datasets has ...

    apktool documentation

    On some devices they might reside in /data/system-framework and even cleverly hidden in /system/app or /system/priv-app. They are usually named with the naming of "resources", "res" or "framework". ...

    Troubleshooting.Xcode.14842156

    If you’ve struggled in the past to make Xcode work as expected, to solve problems that defy logic, and to understand Xcode’s misleading or cryptic error messages and unexpected crashes, ...

    Troubleshooting.Xcode.1484215613

    If you’ve struggled in the past to make Xcode work as expected, to solve problems that defy logic, and to understand Xcode’s misleading or cryptic error messages and unexpected crashes, ...

    SecureCRT简体中文绿色版

    For the latest information on SecureCRT and VanDyke Software, check out our home page: http://www.vandyke.com Get all the latest information about VanDyke Software products in a single monthly e-...

    minimal_perl_for_unix_and_linux_people.pdf

    In this preface, I’ll tell you about the history of Minimal Perl and the origins of this book. THE HISTORY OF MINIMAL PERL The seeds of this book were sown many years ago, when I was building up my ...

    Serv-U Keygen

    * Configurable messages for sign-on, sign-off, login, and directory changes. * Has a 'time-out' feature, so connections are automatically cleared when idle or hung. * Easy to setup and maintain...

    a project model for the FreeBSD Project.7z

    FreeBSD has during the past few year increased both its mass of active users and committers, and the communication in the project has risen accordingly. This project model will serve to reduce this ...

    sorttest 各种排序算法

    # Use an ASCII text editor of your choice (eg NotePad) and enter # the numbers along with line comments. SortTest then allows to # read in all the numbers of the file. Also a subset having fewer # ...

Global site tag (gtag.js) - Google Analytics