`

1002. A+B for Polynomials (25)

c++ 
阅读更多
This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

AC参考代码:
/*主要可能发生错误的测试点: 
  1:格式不正确(数据前后的空格)
  2:系数非零存在,不是非负 
*/ 
#include <stdio.h>
#include <string.h>
int main()
{
	float eff;
	int K,N;	//1<=K<=10
	float arr[2][1001];
	memset(arr,0.0,sizeof(arr));	//初始化数组 
	
	for(int num=0;num<2;num++){
		scanf("%d",&K);
		for(int i=0;i<K;i++){
			scanf("%d %f",&N,&eff);
			arr[num][N] = eff;
		}
	}
	int nonZeroCount = 0;
	for(int j=0;j<1001;j++){
		arr[0][j] += arr[1][j];
		nonZeroCount += arr[0][j]!=0.0 ? 1:0;
	}
	printf("%d",nonZeroCount);
	for(int i=1000;i>=0;i--){
		if(arr[0][i]!=0){
			printf(" %d %.1f",i,arr[0][i]);
		}
	}
	return 0;
}



简单的水过~~
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics